Centos install the specified version of php5.6

Environment linux, centos7.x

The php version in the default source of centos7.x is 5.4
Due to project needs, install a high version of PHP, such as the version above 5.6

The installation steps are as follows:

Set up a third-party source

yum install epel-release
rpm -Uvh https://mirror.webtatic.com/yum/el7/webtatic-release.rpm

Installation

yum install php56w

If you still need php-fpm service, you also need to install
yum install php56w-fpm

Last viewed

php -v

1
2
3
4
5
[me@VM_0_14_centos ~] # php -v
PHP 5.6.40 (cli) (built: Jan 12 2019 13:11:15)
Copyright (c) 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies
[me@VM_0_14_centos ~] #

View English documentation

Persist in original technology sharing, your support will encourage me to continue to create!